X

HTC has issued a warning that some aspects of their new Sense 3.0 will not work on what HTC has decribed as older phones.


Among the phones that will affected are the  HTC Desire S and the HTC Incredible S, which was launched last week in Australia and will be available on the on the Optus network in May.

In a Twitter post over the weekend the Taiwanese firm said: “Clarification: There are aspects of the latest HTC Sense that won’t work on some of our previous devices. We are working to incorporate other aspects that will. Stay tuned.”

LB 728x90 HTC Issues Warning About Sense 3.0
4SQM banner 728x90px SOUL HTC Issues Warning About Sense 3.0
720 x 97 1 HTC Issues Warning About Sense 3.0
SmartHouse Yoga Slim Carbon 728 x 90 HTC Issues Warning About Sense 3.0
4Squre Ads 07 728x90 1 HTC Issues Warning About Sense 3.0
BW HT Upgrade 728x90 1 HTC Issues Warning About Sense 3.0
Versa3 Leaderboard 728x90 HTC Issues Warning About Sense 3.0
Frame 728x90 HTC Issues Warning About Sense 3.0
en us WD Black Banners Portfolio 728x90 HTC Issues Warning About Sense 3.0
Flick of a switch 728x90 1 HTC Issues Warning About Sense 3.0


YOU MAY ALSO LIKE